Having trouble with ECAE. display
Updated on August 17, 2020 in Easy Custom Auto Excerpt
Premium  7 on August 5, 2020

Having trouble with ECAE.
Low priority.

I use a custom shortcode to insert a brief introductory sentence at the top of many posts. This is separate from the excerpt. After the intro, I have set up ECAE for a certain number of characters, after which is displayed a "Read More" button (Read More ➦). Everything looks perfect on the initial display of ten posts on the home page.

However, when a visitor clicks the "Load More Posts" button, the next group of posts do not display the short intro (from my shortcode) and the Read More button is displayed as "Read More »".

WordPress version: 5.4.2
Editor: Classic
ECAE version: 2.4.12 with Pro version 1.5.2
Theme: Soledad 7.2.3 from

https://themeforest.net/item/soledad-multiconcept-blogmagazine-wp-theme/12945398

Penci Design

Thank you.

Tod

  • Liked by
By using the forum you are agree with tonjoo studio license agreement
Moderator 0 on August 5, 2020

Hello,

Do you have any staging version of your website? So we can check it safely.

Sincerely,
Tonjoostudio support

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Premium  0 on August 5, 2020

No, I’m sorry I don’t. However, I recently backed it up.

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Premium  0 on August 8, 2020
  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Moderator 0 on August 12, 2020

Hello,

It seems like the theme doesn’t support plugin ECAE when theme wants to show the content from ajax. The excerpt location setting is on blog page, front page, archive, and search. Ajax load more from the theme Soledad use hook wp_ajax, so it didn’t fulfill the condition in those 4 pages.

Sincerely,
Tonjoostudio support

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Premium  0 on August 16, 2020

Thank you.

What can I do to change this? If I contact the Soledad developer, what detailed technical information can I provide?

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Premium  0 on August 17, 2020

Hi – I contacted the dev of my theme and they replied with this message:

First, you should ask author of the plugin about how to make it works with ajax. Because all WordPress themes should be used hook wp_ajax from WordPress itself. Doesn’t use custom ajax.
So, the explain from author of the plugin is not satisfactory. The plugin should be make it works fine with functions from WordPress.

I feel like I’m stuck between two rocks with this. Any chance of figuring this out?

Thank you,

Tod

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Premium  0 on August 17, 2020

Please mark this as resolved.

The dev of my theme compared my site that was having problems with another site using a different theme where everything works fine, and sent this message:

1/ Because you’re using number pagination on the site: https://scruffydog.org/ – so, of course it doesn’t affect anything.
If you want to get it works like that, you can go to Customize > General Options > and un-check to "Enable Load More Button" and check to "Enable Pagination Numbers" – and it will works the same.

Once I changed those two settings, everything is working perfectly.

Thank you for your own suggestions.

I just renewed my license.

Best regards!

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Loading more replies
You are not logged in

Please login here or simply sign up here .