Read more always showing
Updated on October 21, 2019 in Easy Custom Auto Excerpt
5 on January 31, 2016

Hi!

Thanks for a great plugin. I was wondering about the Read more link showing up on all the posts, even the really short ones. I have the “Display option” set as “Normal”, which should eliminate the link if the whole post is indeed being shown. What to do? I can’t share a link to my blog since it’s for my company and can’t share unfinished work.

Thanks!

– Jaakko Pöntinen

  • Liked by
By using the forum you are agree with tonjoo studio license agreement
Moderator 0 on February 1, 2016

Hi,

Pardon me, but I don’t get it. What do you want to achieve? Can you please elaborate?

You can set the readmore button to shown up based on first paragraph if you think characters is too short.

Thank you :)

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
0 on February 1, 2016

Hi Zea,

What I’m trying to achieve is the “Read more…” button to not show if the whole post did actually fit in the excerpt in the first place.

For example, there’s no need for the “Read more…”, if all the blog entry contains is “Hello, world!”.

For another example, if I write a 3000 word post about gummi bears, I definately want the “Read more…” to show after the set number of letters, paragraphs or however I set the excerpt length.

The options ECAE gives for this under “Read More Button” settings tabs are “Normal, Always show, Always hide”. I have it set on normal, but it acts like it’s set to “Always show”. The settings tab gives the explanation as follows: “Normal mode = show readmore button, only if content length is bigger than excerpt size“, however, as stated, my “Read More” button always shows, which it should not.

Thanks for the reply!

– Jaakko Pöntinen

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Moderator 0 on February 2, 2016

Hi,

Oh… I see…

Have you tried using Excerpt size based on characters? If you using characters, and not paragraph, then the "read more" button will be displayed IF it meets the minimum character… For example :

You set ECAE button to displayed after 500 characters, then if your post is more than 500 characters it’ll shown up. But, if it’s less than 500 characters, then no read more button will displayed, and all post will be shown instead :)

Thank you

  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
1 on October 21, 2019

Excerpts on mine show ‘read more’ button on all, regardless of post length.

on October 21, 2019

Hi,
Would you mind if you open a new thread and explain us more clearly about your problem? Maybe your url or screenshot of your problem will help us a lot understanding your problem.

Show more replies
  • Liked by
Cancel
By using the forum you are agree with tonjoo studio license agreement
Message :
Loading more replies
You are not logged in

Please login here or simply sign up here .